Allfunapps.com
This app requires the Google Chrome Browser. If you are having issues with the app, you will need to install Google Chrome

If you are having issues playing sound, you will need to install Adobe Flash (v.10 or later).
This is required for Learn Elementary Sight Words to work properly.

Questions/Support can be found at http://www.allfunapps.com/support.htm